This project has moved and is read-only. For the latest updates, please go here.

Issues with installation

Jan 29, 2013 at 6:26 PM
Edited Jan 29, 2013 at 6:27 PM

I am facing issues while deploying the FBA pack 

The moment I run deploy.ps1 even the other scripts, Undeploy and Activate get kicked off

 

I get the following error

PS E:\FBA> .\Deploy.ps1 https:\\sp2013\sites\sitename
Security warningRun only scripts that you trust. While scripts from the internet can be useful, this script can potentially harm your computer. Do you want to runE:\FBA\Deploy.ps1?[D] Do not run  [R] Run once  [S] Suspend  [?] Help (default is "D"): R
Security warningRun only scripts that you trust. While scripts from the internet can be useful, this script can potentially harm your computer. Do you want to runE:\FBA\UnDeploy.ps1?[D] Do not run  [R] Run once  [S] Suspend  [?] Help (default is "D"): dFile E:\FBA\UnDeploy.ps1 cannot be loaded because you have elected to not runthis software now.    + CategoryInfo          : SecurityError: (:) [], ParentContainsErrorRecord   Exception    + FullyQualifiedErrorId : UnauthorizedAccessrestart-service : Service 'SharePoint Timer Service (SPTimerV4)' cannot bestopped due to the following error: Cannot open SPTimerV4 service on computer'.'.At E:\FBA\Deploy.ps1:58 char:1+ restart-service SPTimerV4+ ~~~~~~~~~~~~~~~~~~~~~~~~~    + CategoryInfo          : CloseError: (System.ServiceProcess.ServiceContro   ller:ServiceController) [Restart-Service], ServiceCommandException    + FullyQualifiedErrorId : CouldNotStopService,Microsoft.PowerShell.Command   s.RestartServiceCommand

Am I doing something wrong, please help me get over this error

Jan 29, 2013 at 6:42 PM

Undeploy and Activate do run - Undeploy to remove an old version of the FBA Pack if it already exists. Activate to reactivate the FBA Pack features on Site Collections that had it activated before the deploy.  For new installs, the scripts run but don't do anything.

You have to chose R every time for the scripts to run properly.

Jan 30, 2013 at 2:46 PM

Thank you so much for the quick help, I was able to install the solution successfully