This project has moved and is read-only. For the latest updates, please go here.

Issue installing Sharepoint2013

Feb 21, 2013 at 9:22 AM
I am logged onto the sharepoint server as domain admin and have been trying to run the deploy script as follows
.\deploy https://servername.domain.co.uk/sites/InternalUsers

when running the script I get the following error

PS C:\temp> .\deploy https://ServerName.DomainName/sites/Internalusers
Going to uninstall feature
Going to uninstall solution
Waiting for job to finish
Waiting to finish job solution-deployment-visigo.sharepoint.formsbasedauthentication.wsp-0........Finished waiting for job..
Going to remove solution
Going to add solution

Name SolutionId Deployed

visigo.sharepoint.formsbase... 956715d5-f34c-4b00-bfb7-8c35d5fa0f62 False
Going to install solution to all web applications
Waiting for job to finish
Waiting to finish job solution-deployment-visigo.sharepoint.formsbasedauthentication.wsp-0.....Finished waiting for job.
.
Deactivating/activating active features to ensure activation script is run
Going to enable Feature
Enable-spfeature : The Feature is not a Farm Level Feature and is not found in a Site level defined by the Url
https://ServerName.DomainName/sites/Internalusers.
At C:\temp\Activate.ps1:29 char:2
  • Enable-spfeature -identity $featureName -confirm:$false -url $url
  • ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    • CategoryInfo : InvalidData: (Microsoft.Share...etEnableFeature:SPCmdletEnableFeature) [Enable-SPFeature
      ], SPCmdletException
    • FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletEnableFeature
Feb 21, 2013 at 1:56 PM
I think it's an issue with the url you're using. You need to use the url to a Site Collection, not an individual site. Alternatively you can leave the url out, but then you will have to manually activate the feature in Site Settings -> Site Collection Features.
Feb 21, 2013 at 2:29 PM

Hi,

Thank you for the response

I am a little confused as in SharePoint if I navigate to Site Collection Administrators, it says the site collection is https://servername.domain.co.uk/sites/InternalUsers

Peter Newman
Managing Director

Cashbacs International Limited
The Boathouse Business Centre
1 Harbour Square
Nene Parade
Wisbech
Cambridgeshire
PE13 3BH

http://www.linkedin.com/img/signature/pic_plastic_slate_26x130.gif

Support

01945 427030

Sales

01945 580615

Fax

01945 427039

Mobile

07791 873340

Email

pete@cashbacs.co.uk

View Peter Newman's profile on LinkedIn


This e-mail and any files attached to it are confidential and intended for use of the individual or entity to whom they are addressed. If you have received this e-mail in error please notify me immediately by reply and delete this e-mail and any attachments from your system.
It is possible for data that is transmitted by e-mail to be corrupted or intercepted. For this reason, Cashbacs International Limited does not accept any responsibility for any breach of confidence which may arise through the use of this medium.

Cashbacs International Limited registered in England, Number 2130078
Registered Office The Boathouse Business Centre, 1 Harbour Square, Nene Parade, Wisbech, Cambridgeshire, PE13 3BH
VAT registration number: 479 1217 29

From: ccoulson [email removed]
Sent: 21 February 2013 13:59
To: Peter Newman
Subject: Re: Issue installing Sharepoint2013 [sharepoint2013fba:433930]

From: ccoulson

I think it's an issue with the url you're using. You need to use the url to a Site Collection, not an individual site. Alternatively you can leave the url out, but then you will have to manually activate the feature in Site Settings -> Site Collection Features.

Jan 8, 2014 at 9:39 PM
I also get the same errors as PeteN. when running the script and I have tried it without the url as well and the same errors in sharepoint powershell.
Jan 9, 2014 at 6:23 PM
You get the same errors when you just run:

.\deploy

with no parameters?

I just find that strange, since the errors he has was activation errors, and it shouldn't activate it when no url is provided. Can you please paste the output you're getting in powershell.