This project has moved and is read-only. For the latest updates, please go here.

Missing Assembly

Mar 19, 2013 at 9:29 PM
Edited Mar 19, 2013 at 9:32 PM
Hi,
i got a question on an issue.
I followed your instruction for installing FBA Pack 2013 as well as the tutorial for configurating Share Point 2013.
It all runs well up to the point where i get to deploy the FBA Pack. I am choosing a site collection url to deploy on, it runs with no error, and when i get to the site settings section on my central administration site, all the FBA Options are shown, but when i am trying to open 'FBA Site Configuration', 'FBA Role Management' or 'FBA User Management', i get an error telling me,

the file or assembly "Visigo.Sharepoint.FormsBasedAuthentication, Version=1.0.0.0, Culture=neutral, PublicKeyToken=9dba9f460226d31d" or one of its dependancies could not be found

I am running windows server 2012 standard with sql server 2012 express advanced and sharepoint 2013 foundation via VirtualBox, all applications but FBA Pack 2013 are german versions.

Thank you and i appreciate your work.

Greetings
Thomas
Mar 22, 2013 at 5:53 AM
Edited Mar 22, 2013 at 5:54 AM
The tools are meant to be run from a site you deploy to, not central admin (i've never tested it with Central Admin - but I have my doubts that it would work as is, as you can't specify the membership provider or role provider for central admin, which the FBA Pack uses). Try it from the site collection that you deployed it to. If you still have issues:
  • Go to Solution Management in Central Admin and ensure the solution shows as being deployed to the Web Application the site collection resides on.
  • From the Site Collection, Site Settings, select 'Site Collection Features' and ensure that the Forms Based Authentication Management feature is enabled. (You won't see the FBA menu items unless it is).
  • Make sure that you are logged into the site collection as a site admin (or you will not have access to the FBA Management tools).
And if all else fails - redeploy.
Mar 23, 2013 at 10:49 AM
stupid me, that didn't come to my mind. It is working on my site collection. Thank you for your advice