This project has moved and is read-only. For the latest updates, please go here.

Membership Provider error on Win2012

Aug 29, 2013 at 4:55 PM
Hello,

I setup FBA on a WINDOWS 2012 SERVER and followed the instructions on :
http://blogs.visigo.com/chriscoulson/configuring-forms-based-authentication-in-sharepoint-2013-part-3-editing-the-web-config-files/

When I try to use it I got an error : A Membership Provider has not been configured correctly. Check the web.config setttings for this web application.
I got this error for example when I try to add the membership request WebPart.

I am sure that all settings are correct : I set the changes in the machine.config en the securityToken Application and reviewed them many times and I am aso sure that the accounts have the rights they need for connection to the database

I even tried a fresh installation on an new server, to no avail.

I don't find any information about this in the logs. Has anyone got this working on Windows 2012.

I have done many installations of the FBA pack on Win2008r2 succesfully.
Sep 2, 2013 at 4:54 AM
The error message means that it can't make a successful call to the membership provider - which generally means there is an issue with the membership provider setup somewhere.

Have you added users to the membership database from another management tool (iis?) and tried to login with the credentials.

If you're sure that the machine.config is correct, and that the web.config's are properly inheriting from the machine.config, it usually is a permission issue.

You may want to run SQL Profiler to see if any calls are making it through to the database (or at least be able to see if there are authentication errors). Check profiler when you get the "Membership Provider has not been configured correctly" message, as it is sending a query to the database at that time.
Sep 12, 2013 at 6:13 PM
I'm having the same issue. I am able to add a user using IIS and able to login. (I haven't set up the account so I get the site has not been shared error). I've tried SQLProfiler and I don't see anything coming through. I've confirmed that I see the SQL queries when I login, but not when I open the Manage Users page. What else should I look for?
Sep 13, 2013 at 1:48 PM
I also had the same issue and traced it back to the fact that the aspnetdb database did not give read/write permissions to the Application Pool's Service Account of the SharePoint site hosting the web parts.

So far all working fine on Windows 2012.

Cheers

Sebastian
Sep 13, 2013 at 2:36 PM
If you can login but the user management page isn't working, another thing to look for is differences between your securetokenservice web.config and your web application web.config/machine.config. The securetokenservice web.config membership settings are used to login. Your web application config membership settings are used within the web application (web parts, management pages...)
Sep 14, 2013 at 1:25 PM
I've checked that as well and it appears to be the same. I've downloaded the code and I plan on stepping through it sometime this weekend or next week and I'll post an update when I know what the issue is.

Thanks,
Oct 19, 2014 at 4:03 AM
Make sure that you are accessing the web application from the zone that is configured for FBA. In my case, I was getting the error as I am trying to access the web application from the default zone URL.