This project has moved and is read-only. For the latest updates, please go here.

FBA Permissions

Jun 1, 2014 at 4:22 PM
I built a new SharePoint 2013 site and moved ContentDB's from our old SharePoint 2010 site.
I installed the SharePoint 2013 FBA Pack, and can log in with an FBA Account. But when I log in with an Admin Windows Account and look at Users and Permissions, there are no FBA items listed to add users, membership, etc.

If I uninstall SharePoint 2013 FBA pack and instal the 2010 Pack, then the FBA items are listed. I can then add a new FBA User, except the FBA User has access to all the folders listed where previously, I had to add them to the folders for which you would have access to.

Any ideas?
Jun 1, 2014 at 7:52 PM
So the extra menu items aren't showing up in Site Settings?

Make sure that you're logged in as a Site Collection Administrator, or you won't see them.

Additionally, check the Site Collection Features and make sure that the Forms Based Authentication Management feature is activated (Or they won't show as well).
Jun 1, 2014 at 8:19 PM
Here is the error I get when deploying FBA2013:

PS C:\Users\SP_Admin\Downloads\SharePoint2013FBA1.3.4> .\Deploy.ps1 https://server.domain.com:443
Solution not installed
Going to add solution

Name SolutionId Deployed

visigo.sharepoint.formsbase... 956715d5-f34c-4b00-bfb7-8c35d5fa0f62 False
Going to install solution to all web applications
Waiting for job to finish
Waiting to finish job solution-deployment-visigo.sharepoint.formsbasedauthentication.wsp-0......Finished waiting for job..
Deactivating/activating active features to ensure activation script is run
Going to enable Feature
Enable-spfeature : The Feature is not a Farm Level Feature and is not found in a Site level defined by the Url https://server.domain.com:443.
At C:\Users\SP_Admin\Downloads\SharePoint2013FBA1.3.4\Activate.ps1:29 char:2
  • Enable-spfeature -identity $featureName -confirm:$false -url $url
  • ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    • CategoryInfo : InvalidData: (Microsoft.Share...etEnableFeature:
      SPCmdletEnableFeature) [Enable-SPFeature], SPCmdletException
    • FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletEnableFe
      ature
PS C:\Users\SP_Admin\Downloads\SharePoint2013FBA1.3.4>
Jun 1, 2014 at 9:10 PM
Found the issue. Running SharePoint 2013, a SharePoint 2010 Content DB was used. Created a new site, Deploy works fine.
Jun 1, 2014 at 10:38 PM
So the issue really is is updating a SharePoint 2010 ContentDB to SharePoint 2013 that had SharePointFBA2010 installed.

I detached the DB, copied it to the new SQL Svr and attached it. Then I deleted the ContentDB from the newly created Web App and ran the Test-SPContentDatabase command. The results are:

PS C:\Users\SP_Admin> Test-SPContentDatabase -Name SP2010_LatamDB -WebApplicatio
n https://server.domain.com


Category : MissingFeature
Error : True
UpgradeBlocking : False
Message : Database [SP2010_LatamDB] has reference(s) to a missing
              feature: Id = [d57f4817-f1f9-42aa-863c-139804c731b0], Name =
              [Forms Based Authentication Management], Description =
              [Forms and web parts for managing Forms Based
              Authentication], Install Location = [FBAManagement].
Remedy : The feature with Id d57f4817-f1f9-42aa-863c-139804c731b0 is
              referenced in the database [SP2010_LatamDB], but is not
              installed on the current farm. The missing feature may cause
              upgrade to fail. Please install any solution which contains
              the feature and restart upgrade if necessary.
Locations :

Category : MissingSetupFile
Error : True
UpgradeBlocking : False
Message : File [Features\FBAManagement\ChangePasswordWebPart\ChangePass
              wordWebPart.webpart] is referenced [1] times in the database
              [SP2010_LatamDB], but is not installed on the current farm.
              Please install any feature/solution which contains this file.
Remedy : One or more setup files are referenced in the database
              [SP2010_LatamDB], but are not installed on the current farm.
              Please install any feature or solution which contains these
              files.
Locations :

Category : MissingSetupFile
Error : True
UpgradeBlocking : False
Message : File [Features\FBAManagement\MembershipRequestWebPart\Members
              hipRequestWebPart.webpart] is referenced [1] times in the
              database [SP2010_LatamDB], but is not installed on the
              current farm. Please install any feature/solution which
              contains this file.
Remedy : One or more setup files are referenced in the database
              [SP2010_LatamDB], but are not installed on the current farm.
              Please install any feature or solution which contains these
              files.
Locations :

Category : MissingSetupFile
Error : True
UpgradeBlocking : False
Message : File [Features\FBAManagement\PasswordRecoveryWebPart\Password
              RecoveryWebPart.webpart] is referenced [1] times in the
              database [SP2010_LatamDB], but is not installed on the
              current farm. Please install any feature/solution which
              contains this file.
Remedy : One or more setup files are referenced in the database
              [SP2010_LatamDB], but are not installed on the current farm.
              Please install any feature or solution which contains these
              files.
Locations :

Running the Mount-SPConentDatabase gave me this:

PS C:\Users\SP_Admin> Mount-SPContentDatabase -Name SP2010_LatamDB -WebApplicati
on https://server.domain.com
100.00% : SPContentDatabase Name=SP2010_LatamDB
Mount-SPContentDatabase : Upgrade completed with errors. Review the upgrade
log file located in C:\Program Files\Common Files\Microsoft Shared\Web Server
Extensions\15\LOGS\Upgrade-20140601-171921-465.log. The number of errors and
warnings is listed at the end of the upgrade log file.
At line:1 char:1
  • Mount-SPContentDatabase -Name SP2010_LatamDB -WebApplication
    https://latam.clinl ...
  • ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    ~~~
    • CategoryInfo : InvalidData: (Microsoft.Share...ContentDatabase:
      SPCmdletMountContentDatabase) [Mount-SPContentDatabase], SPUpgradeExceptio
      n
    • FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletMountCon
      tentDatabase
The error log provided:

Timestamp Process TID Area Category EventID Level Message Correlation
06/01/2014 17:19:21.68 powershell (0x0E80) 0x07C0 SharePoint Foundation Upgrade SPContentDatabaseSequence ajxkg INFO SPContentDatabase Name=SP2010_LatamDB dcb69034-1fd2-4530-9a70-bcd8444287f5
06/01/2014 17:19:21.68 powershell (0x0E80) 0x07C0 SharePoint Foundation Upgrade SPContentDatabaseSequence ajxkg ERROR Found a missing feature Id = [d57f4817-f1f9-42aa-863c-139804c731b0], Name = [Forms Based Authentication Management], Description = [Forms and web parts for managing Forms Based Authentication], Install Location = [FBAManagement] dcb69034-1fd2-4530-9a70-bcd8444287f5
06/01/2014 17:19:21.68 powershell (0x0E80) 0x07C0 SharePoint Foundation Upgrade SPContentDatabaseSequence ajxkh INFO SPContentDatabase Name=SP2010_LatamDB dcb69034-1fd2-4530-9a70-bcd8444287f5
06/01/2014 17:19:21.68 powershell (0x0E80) 0x07C0 SharePoint Foundation Upgrade SPContentDatabaseSequence ajxkh ERROR The feature with Id d57f4817-f1f9-42aa-863c-139804c731b0 is referenced in the database [SP2010_LatamDB], but is not installed on the current farm. The missing feature may cause upgrade to fail. Please install any solution which contains the feature and restart upgrade if necessary. dcb69034-1fd2-4530-9a70-bcd8444287f5
06/01/2014 17:19:21.71 powershell (0x0E80) 0x07C0 SharePoint Foundation Upgrade SPContentDatabaseSequence ajxj6 INFO SPContentDatabase Name=SP2010_LatamDB dcb69034-1fd2-4530-9a70-bcd8444287f5
06/01/2014 17:19:21.71 powershell (0x0E80) 0x07C0 SharePoint Foundation Upgrade SPContentDatabaseSequence ajxj6 WARNING File [Features\FBAManagement\ChangePasswordWebPart\ChangePasswordWebPart.webpart] is referenced [1] times in the database [SP2010_LatamDB], but is not installed on the current farm. Please install any feature/solution which contains this file. dcb69034-1fd2-4530-9a70-bcd8444287f5
06/01/2014 17:19:21.71 powershell (0x0E80) 0x07C0 SharePoint Foundation Upgrade SPContentDatabaseSequence ajxj7 INFO SPContentDatabase Name=SP2010_LatamDB dcb69034-1fd2-4530-9a70-bcd8444287f5
06/01/2014 17:19:21.71 powershell (0x0E80) 0x07C0 SharePoint Foundation Upgrade SPContentDatabaseSequence ajxj7 WARNING One or more setup files are referenced in the database [SP2010_LatamDB], but are not installed on the current farm. Please install any feature or solution which contains these files. dcb69034-1fd2-4530-9a70-bcd8444287f5
06/01/2014 17:19:21.71 powershell (0x0E80) 0x07C0 SharePoint Foundation Upgrade SPContentDatabaseSequence ajxj6 INFO SPContentDatabase Name=SP2010_LatamDB dcb69034-1fd2-4530-9a70-bcd8444287f5
06/01/2014 17:19:21.71 powershell (0x0E80) 0x07C0 SharePoint Foundation Upgrade SPContentDatabaseSequence ajxj6 WARNING File [Features\FBAManagement\MembershipRequestWebPart\MembershipRequestWebPart.webpart] is referenced [1] times in the database [SP2010_LatamDB], but is not installed on the current farm. Please install any feature/solution which contains this file. dcb69034-1fd2-4530-9a70-bcd8444287f5
06/01/2014 17:19:21.71 powershell (0x0E80) 0x07C0 SharePoint Foundation Upgrade SPContentDatabaseSequence ajxj7 INFO SPContentDatabase Name=SP2010_LatamDB dcb69034-1fd2-4530-9a70-bcd8444287f5
06/01/2014 17:19:21.71 powershell (0x0E80) 0x07C0 SharePoint Foundation Upgrade SPContentDatabaseSequence ajxj7 WARNING One or more setup files are referenced in the database [SP2010_LatamDB], but are not installed on the current farm. Please install any feature or solution which contains these files. dcb69034-1fd2-4530-9a70-bcd8444287f5
06/01/2014 17:19:21.71 powershell (0x0E80) 0x07C0 SharePoint Foundation Upgrade SPContentDatabaseSequence ajxj6 INFO SPContentDatabase Name=SP2010_LatamDB dcb69034-1fd2-4530-9a70-bcd8444287f5
06/01/2014 17:19:21.71 powershell (0x0E80) 0x07C0 SharePoint Foundation Upgrade SPContentDatabaseSequence ajxj6 WARNING File [Features\FBAManagement\PasswordRecoveryWebPart\PasswordRecoveryWebPart.webpart] is referenced [1] times in the database [SP2010_LatamDB], but is not installed on the current farm. Please install any feature/solution which contains this file. dcb69034-1fd2-4530-9a70-bcd8444287f5
06/01/2014 17:19:21.71 powershell (0x0E80) 0x07C0 SharePoint Foundation Upgrade SPContentDatabaseSequence ajxj7 INFO SPContentDatabase Name=SP2010_LatamDB dcb69034-1fd2-4530-9a70-bcd8444287f5
06/01/2014 17:19:21.71 powershell (0x0E80) 0x07C0 SharePoint Foundation Upgrade SPContentDatabaseSequence ajxj7 WARNING One or more setup files are referenced in the database [SP2010_LatamDB], but are not installed on the current farm. Please install any feature or solution which contains these files. dcb69034-1fd2-4530-9a70-bcd8444287f5
06/01/2014 17:20:17.29 powershell (0x0E80) 0x07C0 SharePoint Foundation Upgrade SPSiteWssSequence2 ajy6o INFO SPSite Url=https://latam.clinlogix.com dcb69034-1fd2-4530-9a70-bcd8444287f5
06/01/2014 17:20:17.29 powershell (0x0E80) 0x07C0 SharePoint Foundation Upgrade SPSiteWssSequence2 ajy6o WARNING Feature could not be upgraded. Exception: Feature definition id 'd57f4817-f1f9-42aa-863c-139804c731b0' could not be found. dcb69034-1fd2-4530-9a70-bcd8444287f5

So the site in SharPoint 2013 looks like SharePoint 2010. Do I need to use the FBA2010 in the SharePoint 2013 Web Application?
Jun 2, 2014 at 2:17 AM
No, the 2010 FBA Pack will not work on SharePoint 2013, even if you're using the 2010 UI.

Looking at the error:

Enable-spfeature : The Feature is not a Farm Level Feature and is not found in a Site level defined by the Url https://server.domain.com:443.


I believe the problem is that you are specifying central admin as the deployment target. You should specify the site collection where it will be activated, not central admin. Alternatively you can just run ".\deploy" with no parameters, and then activate the feature on any site collection you would like to use it.
Jun 2, 2014 at 2:49 AM
Edited Jun 2, 2014 at 6:38 AM
I was able to use SharePointFBA2010 on the SharePoint 2013 Sites. I have 2 sites that are new and setup on Sharepoint 2013, but since the other one is from SharePoint 2010, I cannot use FBA 2013.
Jun 4, 2014 at 11:43 PM
Somebody else just ran into the same thing. See here:

https://sharepoint2013fba.codeplex.com/discussions/547565#post1253059

I guess this is something i'll have to look into. I've raised an issue here: https://sharepoint2013fba.codeplex.com/workitem/23