This project has moved and is read-only. For the latest updates, please go here.

How best to present the registration page to new users

Feb 12, 2015 at 1:21 AM
First, thanks for the wonderful program. Just what I was looking for. I have some sites I need to create that will be utilized by about 800 AD users and 2,200 non-AD users. I've setup FBA using the FBA pack and all is up and running properly.

I don't know if it exists, but what I am looking for is some instructions on how to do the following (STEP 5 is my actual question):
  1. For internal users, they will automatically authenticate while in-house, so I have no issue here - this works as expected.
  2. For external user (both AD and non-AD), they will (initially) get the out of the box FBA Sign-In page - this works as expected.
  3. At this point, I want my AD users to select Windows Authentication and go directly to the site - this works as directed.
  4. I want my non-AD users to select Forms Authentication and then login - if they have an existing password (works as expected) OR
  5. I would like them to get to the Member Registration page. I have created the page, but how do I expose this page to them at this point - prior to their having access to the site? If there is a step-by-step that you are aware of can you please provide? I know others must have struggled with this so either I am missing something obvious, or there is more that I have to do.
Once again, thank for the program.

Thanks
Feb 12, 2015 at 1:55 PM
For the member registration page, you can just add the Membership Request web part to a page with anonymous access - so that anybody can access it.

You would have to create a custom login page though if you'd like to add a link to this registration page.
Feb 12, 2015 at 7:58 PM
Fantastic. That works.

Once exception - when I press the Create User button - it just brings me to the Sign In page. I will work with it a little more to see what I can find.

If you happen to have a moment to point me in the right direction, please do.

Thanks again for your quick response.

Joe
Feb 12, 2015 at 8:08 PM
Does the user get created properly and emails go out?

By default it should return the user to the current page. You can modify the web part settings to redirect to a different page though. If you're getting a login page, that would tell me that whatever page you're actually getting directed to is either not available anonymous, or contains content (image, etc..) that's not available anonymously.
Feb 12, 2015 at 10:03 PM
Thanks Chris.

This actually fixed itself - must have been how I was logged in etc. I am now able to get emails out to registrants in testing and approve them appropriately. I think a redirect change makes sense in my case so I will work on that.