The feature is not a farm level feature error

Jun 4, 2014 at 6:08 PM
Hi,

I've been able to install the Visigo.Sharepoint.FormsBasedAuthentication.wsp into SharePoint and when I look in Central Admin I can see it as a deployed solution.

But when I try to activate the feature, I get the following error:
________.
At C:\projects\SharePoint2013FBAPack.1.3.3\Activate.ps1:29 char:2
  • Enable-spfeature -identity $featureName -confirm:$false -url $urlEnable-spfeature : The Feature is not a Farm Level Feature and is not found in
    a Site level defined by the Url http://someserver
  • ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    • CategoryInfo : InvalidData: (Microsoft.Share...etEnableFeature:
      SPCmdletEnableFeature) [Enable-SPFeature], SPCmdletException
    • FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletEnableFe
      ature
Can anyone provide some help on this one? I'm really stuck at this point.
Coordinator
Jun 4, 2014 at 6:11 PM
I think you're trying to activate it on Central Admin itself. The deploy url should be a site collection you want the feature activated on. Alternatively, just run:

./deploy

and manually activate the feature on any site collection you would like to use it on.
Jun 4, 2014 at 6:22 PM
The URL I am using is for port 80 and it is a site collection, and I'm still getting the error. In addition when I log into the site collection and try to activate the feature I don't see the FBA Pack features listed.
Coordinator
Jun 4, 2014 at 6:42 PM
Do you get the error when you just run the command without the url?

In 'Manage Farm Solutions' is the FBA Pack deployed to the web application where your site collection is located?

If so, there should be a 'Forms Based Authentication Management' Feature in the 'site collection features' for the site collection.
Jun 4, 2014 at 8:11 PM
Edited Jun 4, 2014 at 8:12 PM
If I run without the URL, I don't get the error, but I still have the same problem. The visigo wsp shows as deployed, but I still don't see the features under site collection features. So I can't enable them. Does it matter if I'm using SharePoint 2013 foundation?

Here's what I see in Central Admin for the solution:
Name: visigo.sharepoint.formsbasedauthentication.wsp
Type: Core Solution
Contains Web Application Resource: Yes
Contains Global Assembly: Yes
Contains Code Access Security Policy: No
Deployment Server Type: Front-end Web server
Deployment Status: Deployed
Deployed To: http://xxx:82/; http://xxxx/; http://fern:81/ Last Operation Result: The solution was successfully deployed.
Last Operation Details: FERN : http://xxx/ : The solution was successfully deployed.
FERN : http://xxx:81/ : The solution was successfully deployed.
FERN : http://xxx:82/ : The solution was successfully deployed.

Last Operation Time: 6/4/2014 2:00 PM

Here's what I see in the features list for the site colleciton:
$Resources:ReportServerResources,FeatureTitle;
$Resources:ReportServerResources,FeatureDescription;
Custom Site Collection Help
Open Documents in Client Applications by Default
Search Server Web Parts
Three-state workflow

So the solution deploys but the feature never shows up in the Site Collection feature list.
Coordinator
Jun 4, 2014 at 9:45 PM
Hmmm...i'm not sure why that wouldn't be showing then. Maybe you can try undeploying/redeploying the solution from Manage Farm Solutions in Central Admin.
Jun 4, 2014 at 10:25 PM
I believe I have figured it out. I noticed (finally) that my other web apps did see the feature. The one web app I was having issues with was in SharePoint 2013 but was using the SharePoint 2010 experience setting. I installed the SP2010 version of the FBA pack, and now I see the feature and can activate it.

thanks for all your expediate help.

Brian
Coordinator
Jun 4, 2014 at 10:41 PM
Interesting - somebody else mentioned the same thing recently. I'll have to look into this.
Coordinator
Jun 4, 2014 at 10:44 PM