Applying SSL bindings FBA disappears from Site Features

Oct 6, 2014 at 2:30 PM
Hi, I have installed the FBA pack successfully on a Windows 2008 R2 box with SharePoint 2013 and been using the features for about 3 weeks, adding users, configuring email, and marveling at this contribution.

I have Anonymous access enabled on the web application and each site collection set to allow anonymous access to Lists and Libraries. I've been successful in creating anonymous pages for Registration and Password Recovery but now I'm trying to give anonymous access to /_layouts/15/FBA/ChangePassword.aspx without success. Instead I create an anonymous page and insert the Change Password web part into the page but now an anonymous user can view the page but not the web part!

Troubleshooting anonymous access -- one of the first things recommended is confirm whether the FBA pack is activated under Site Collection Features. I look but it is not there. Whoa. Rubbing my eyes. But I deployed the FBA to each individual site. What gives?

My only recent configuration change to the Farm was installing an SSL Certificate and updating the Alternate Access Mappings. No problems there, I can still access all the sites.

But I don't see the FBA pack listed under any of the Site Collection Features in the Farm or in any of the Sites. I could be way off base here but do I need to re-deploy after applying SSL?
Coordinator
Oct 6, 2014 at 2:40 PM
The change password web part and page do not work with anonymous access, as they require the user to be logged in to determine who to change the password for. The membership request and forgot password web parts do work with anonymous access.
Oct 6, 2014 at 2:56 PM
Doh! I totally missed that one. Thanks for the quick reply.