Password Recovery Webpart From Email

Jan 14, 2016 at 2:17 PM
I have the password recovery webpart setup in my SharePoint site. Someone else set it up and left the company. It is setup to use SMTP I noticed. When it sends an email the From address is incorrect. Does anyone know where the webpart gets the From address for the password recovery email? I need to change it.


Looking through the code, I can't tell where it is pulling in from.
Coordinator
Jan 14, 2016 at 2:26 PM
It will default to the email settings in Central Admin (Outgoing Email Settings).

The value though can also be overridden in the FBA Site Configuration page. To access it you need to login to the site collection as a site collection administrator, and then go to Site Settings.
Jan 14, 2016 at 2:30 PM
ccoulson wrote:
It will default to the email settings in Central Admin (Outgoing Email Settings).

The value though can also be overridden in the FBA Site Configuration page. To access it you need to login to the site collection as a site collection administrator, and then go to Site Settings.
I changed the CA Outgoing Email and the email on FBA Site Configuration page. It still has not changed. Do I need to restart anything?
Coordinator
Jan 14, 2016 at 2:34 PM
No need to restart anything. The values are unique to each site/subsite, so the web part is probably running on a different site than where you changed it.
Marked as answer by kjmcsd on 1/14/2016 at 7:48 AM
Jan 14, 2016 at 2:48 PM
ccoulson wrote:
No need to restart anything. The values are unique to each site/subsite, so the web part is probably running on a different site than where you changed it.
Wow. I feel stupid. That makes sense.

I changed the email settings there and it worked.

Thanks for your help. It is a great product.