This project has moved and is read-only. For the latest updates, please go here.

Modifying FBA Pack

Jun 27, 2016 at 8:48 AM
I want to add some more Fields like DOB, so i have added in UserNew.aspx but fields are not showing up in New User Registration.

Any suggestions...

Regards,
Jithendra.
Jun 27, 2016 at 8:50 PM
usernew.aspx is for registering new users on the built in user management page (Site Settings):
http://download-codeplex.sec.s-msft.com/Download?ProjectName=sharepoint2013fba&DownloadId=606165

If you add fields to it, they should show up there. You might want to try just making simple modifications to the page first to make sure they are showing up (perhaps the changes you make aren't getting properly deployed?). You might want to also check the sharepoint log file for error messages.

Alternatively, is it the membership request web part you are trying to modify? In that case you have to modify the templates and code for the web part (not usernew.aspx).
Jun 28, 2016 at 5:31 AM
Thanks @ccoulson , i have edited only usernew.aspx, if it shows up then i will go for code behind, here's the aspx code i have added but it is not showing up.
<!-- Model -->
        <wssuc:InputFormSection runat="server" Title="<%$ Resources:FBAPackWebPages, ModelColHeaderText %>">
            <template_inputformcontrols>
                <asp:Label ID="lblModel" runat="server" Text="" ForeColor="red"></asp:Label>
                <wssuc:InputFormControl runat="server" LabelText="<%$ Resources:FBAPackWebPages, TypeModelLabelText %>">
                    <Template_Control>
                        <SharePoint:InputFormTextBox Title="<%$ Resources:FBAPackWebPages, ModelColHeaderText %>" class="ms-input" Columns="40" maxlength="255" ID="txtModel" Direction="LeftToRight" Runat="server" autocomplete="off" />
                        <SharePoint:InputFormRegularExpressionValidator ID="InputFormModel"  ControlToValidate="txtModel" Display="Dynamic" runat="server" />
                    </Template_Control>
                </wssuc:InputFormControl>
            </template_inputformcontrols>
        </wssuc:InputFormSection>
This should just render a label with the name "Model" and a textbox for it.
i have added the resources in .resx file.
Jun 28, 2016 at 3:05 PM
Yeah, this should show up. I'd probably, at least temporarily, just use standard strings for the text instead of the resource files, to get rid of another possible issue. But my guess is if you're seeing the page, but not seeing this new content, then your solution isn't deploying properly to your site collection and i'd look at that. You can always check if the updated file ended up in the correct folder on the server (because if it did, that's what should be getting served).