This project has moved. For the latest updates, please go here.

e-mail address disappears

Aug 30, 2016 at 3:31 PM
Hey Guys

A customer has a strange problem with SharePoint 2013 FBA Pack 1.3.3.

When he creating a user including e-mail address and save it, the user including the e-mail address appear in the user overview. After a few seconds (sometimes a few minutes) the e-mail address disappears! Re-enter the e-mail address by click on the user doesn't fix the problem!

IMPORTANT: It's not a general problem because some user save their e-mail address without a problem.

System Information:
  • SharePoint 2013 CU January 2016
  • Windows Server 2008R2
  • SharePoint FBA Pack 1.3.3
Can someone help me? Please excuse my bad english.

Kind Regards,
Sandro
Coordinator
Aug 31, 2016 at 1:38 PM
I think what's probably happening is that you're using the 'My Site' and user profile service feature. The FBA Pack only updates the user profile information at the site collection level. And when somebody logs into 'My Site' it updates all site collections with their My Site user profile properties - which doesn't include their name or email address. If they update their name and email address on My Site it should propagate to all site collections they've logged into.
Marked as answer by Bulletmonkey on 9/4/2016 at 11:22 PM
Sep 1, 2016 at 10:10 AM
Hi ccoulson

I don't think so. User A, B & C all doesn't have a "MySite". Of course you can find their user profile in the User Profile Service but all of them doesn't have a e-mail address there. But for example, when you open "FBA User Management" under Websitesettings User C has a e-mail address and User A & B not.

Below you can find a printscreen. Arrows showing the missing e-mail address.

Image

Regards,
Sandro
Coordinator
Sep 1, 2016 at 12:22 PM
That's the only thing I can think of - because the name and email address are there initially, correct? And then they disappear? The only thing I can think of is that something's triggering the user profile service that they've been updated and it overwrites the profile. Maybe try shutting off the user profile service and then updating the values on the site collection - see if at some point they still disappear with the user profile service turned off.
Sep 5, 2016 at 7:22 AM
Hey ccoulson

After I have insert the users e-mail address in UPS, the changes I made in FBA User Managemt persist the adjustments.

Thanks for your help!

Regards,
Sandro